How to Install The Latest GIMP 2.9.5 in Ubuntu 16.04

GIMP 2.9.5

GIMP, one of the most popular Linux image editor, has reached the 2.9.5 development release, which will finally lead to the next stable GIMP release 2.10.

While Ubuntu 16.04 offers GIMP 2.8.16 in its main archive, you may either upgrade to the latest stable release, or try the 2.9 development release by following this simple tutorial.

GIMP 2.9/2.10 Features preview:

  • 16/32 bit per channel support
  • Lossless color space conversions
  • New tool: Unified transformation
  • Heavily improved scaling quality: No- and LoHalo-Samplers
  • Sampling example 2 to see the high quality of the new samplers.
  • More on-canvas previews
  • Multi-core CPU / GPU support
  • OpenCL-accelerated filters
  • GEGL based filters and plugins
  • ICC v4 color profile conversion support
  • Color temperature correction
  • Drop the Lanczos 3 sampler and Maximum RGB filter

How to Install GIMP 2.9.5 via PPA:

1. Add the dev PPA:

Open terminal (Ctrl+Alt+T) and run command:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp-edge

Type in password when it asks and hit Enter.

GIMP DEV PPA

2. Install or upgrade GIMP:

For those who have a previous release installed, you can now upgrade GIMP via Software Updater utility:

upgrade to gimp 2.9.5

Or just run the commands below on terminal to install GIMP 2.9.5:

sudo apt update && sudo apt install gimp gimp-gmic

3. Revert to GIMP stable release

Since GIMP 2.9 is unstable development release, there might be bugs and stability issues. You can easily revert to the stable GIMP 2.8.16, the stock version in Ubuntu 16.04 by running the commands below in terminal:

sudo apt install ppa-purge && sudo ppa-purge ppa:otto-kesselgulasch/gimp-edge

About ml

ml is a part time stay-at-home dad who've been using Ubuntu Desktop for a few years. He writes in the free time and wishes to share some useful tips with Ubuntu beginners and lovers.
  • Hal Tutor

    I keep getting the error message ”
    Updating packages lists
    W: The repository ‘cdrom://Ubuntu 16.04.1 LTS _Xenial Xerus_ – Release i386 (20160719) xenial Release’ does not have a Release file.
    E: Failed to fetch cdrom://Ubuntu 16.04.1 LTS _Xenial Xerus_ – Release i386 (20160719)/dists/xenial/main/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
    E: Some index files failed to download. They have been ignored, or old ones used instead.
    Warning: apt-get update failed for some reason


    is there something I am doing wrong? trying to install GIMP after a new install of Ubuntu 16.04.

    • merill0

      Go to System Settings -> Software & Updates -> the first Ubuntu Software tab, uncheck the box under “installable from CD-ROM/DVD”.

      Then re-do the commands.

      • Hal Tutor

        I noticed that option in previous Ubuntu (and Zorin) versions, but this time there was no box to uncheck. Could there be something wrong with the ISO of 16.04LTS?

        • merill0

          Ubuntu 16.04 or Zorin? Try edit the source file via command:

          gksudo gedit /etc/apt/sources.list

          Install gksu if the command does not work. Find out the line looks like:

          deb cdrom:[Ubuntu 16.04 LTS _Xenial Xerus_ – Beta amd64 (20160323)]/ xenial main restricted

          Then comment or remove it and save the file.

          And this is my 16.04 sources:

          deb http://archive.ubuntu.com/ubuntu xenial main restricted
          deb-src http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse #Added by software-properties
          deb http://archive.ubuntu.com/ubuntu xenial universe
          deb http://archive.ubuntu.com/ubuntu xenial multiverse
          deb http://security.ubuntu.com/ubuntu/ xenial-security universe main multiverse restricted
          deb http://archive.ubuntu.com/ubuntu xenial-updates universe main multiverse restricted
          deb http://archive.ubuntu.com/ubuntu xenial-backports universe main multiverse restricted

          • Hal Tutor

            well, this is strange. After installing cairo-dock and rebooting into 16.04, GIMP and VLC both installed immediately. Not sure why. I checked the sources list and it is the same as the one you list. This is a new install of 16.04 along side Zorin 9. The Zorin installed everything easily and quickly, including GIMP. Not sure why the 16.04 is being clunky. But… on to getting 16.04 to stay connected on WIFI (something Zorin has had no trouble doing either).

            Thanks so much for your assistance. I’d called this problem solved, even though I cannot explain exactly why or how. 😉

  • Dominik KrzemiƄski

    I have a problem with backing to stable GIMP 2.8.18 i have this error message:

    The following packages have unmet dependencies.
    gimp : Depends: libgimp2.0 (<= 2.8.18-z) but 2.9.5~20-0x0~ppa~6813dd0 is to be installed
    Depends: gimp-data (<= 2.8.18-z) but 2.9.5~20-0x0~ppa~6813dd0 is to be installed

    I typed in terminal:

    sudo apt install ppa-purge && sudo ppa-purge ppa:otto-kesselgulasch/gimp-edge

    and now i can't install both versions of GIMP :/

    • merill0

      Try command to auto-remove the GIMP 2.9.x dependency libraries:

      sudo apt autoremove

      Or manually remove them via:

      sudo apt remove libgimp2.0 gimp-data

      After that, re-install GIMP 2.8 via the stable PPA.

      • Dominik KrzemiƄski

        Thanks @merill0:disqus i used a:
        sudo aptitude purge libgimp2.0

        sudo aptitude purge gimp-data
        and it resolve problem with libraries